CCrrccppttoo Command

CC Version 1.1

This software is provided "as is" without warranty of any kind. The author disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall the author be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages.

Even though CC is freeware, it is not in the public domain, I reserve all rights to it. You may freely distribute copies of CC as long as you do so in an unmodified form and include all files and documentation that are present in the original archive. You may not charge for the distribution of CC other than a reasonable fee to cover your distribution costs.

The CC (CCrryyppttoo Command) command line tool is one of the applications of the "CCrryyppttoo Suite". CC enables you to encrypt or decrypt files using the command console.

Author

Harald-René Flasch
mailto:hfr@hfrmobile.com
http://www.hfrmobile.com

Parameter

All parameters are case sensitive. Here is a complete list of all CC parameters:

  • /?, /h
  • /disclaimer
  • /nologo
  • /nl
  • /echo
  • /f
  • /p
  • /P
  • /kt
  • /!a
  • /!A
  • /!e
  • /!d

Return values

After execution CC returns a value to his caller. This return value can be used in batch files (e.g. *.cmd or *.bat). You can use the %errorlevel% environment variable in order to retrieve the return value.

Here is a complete list of all possible return values:

0 | CC successfully executed
1 | Internal error. Maybe missing the DLL mfc42.dll
2 | Passwords to not match. Only occurs if using the /P parameter
3 | An unknown parameter was specified
4 | No password and/or no file was specified (use /f and/or /P or /p parameter)
5 | No file was specified. Use /f parameter!
6-9 | Not used
10 | Wrong password
11 | An error occurred while encrypting or decrypting. Maybe the file to encrypt/decrypt is read−only or not enough memory is available.

History

The following table contains all released versions of CC:

Version Description
1.1
  • backward compatibility with Version 1.0
  • additional parameters: /nl, /echo, /!a, /!A and /kt
  • improved error handling and return values
  • improved setup
1.0 Beta1
  • First release


CC /?, /h

/?
/h

Syntax: /? or /h

The /? or /h parameter can be used to display a short description of each CC parameter. If no parameter is specified program information, parameter description and usage are displayed anyway.

This help provides some more detailed description of CC parameters.


CC /disclaimer

/disclaimer

Syntax: /disclaimer

The /disclaimer parameter displays important information about CC. The disclaimer which is displayed is the same which you can see at the top of the page Contents.


CC /nologo

/nologo

Syntax: /nologo

The /nologo parameter can be used to suppress program information, parameter description and usage information.

See also: /nl, /echo


CC /nl

/nl

Syntax: /nl

The /nl ("new line") parameter is used to print a line feed. This is useful if you like to format the output of CC. You can use this parameter (like all others) any time.

See also: /echo


CC /echo

/echo

Syntax: /echo <text>

The /echo parameter can be used to display the specified text. This is useful if you like to format the output of CC. You can use this parameter (like all others). any time.

Value | Description
<text> | Text to display. If the text contains spaces you have to use quotation marks.

See also: /nl


CC /f

/f

Syntax: /f <filename>

The /f parameter specifies a file which should be encrypted or decrypted. This parameter has also to be used if you like to know some information of a file (e.g. if using /!A in order to determine if a file is encrypted or not).

Value | Description
<filename> | Name of the file. If no path is specified the file must be located in the same directory. If the filename contains spaces you have to use quotation marks.


CC /p

/p

Syntax: /p <password>

The /p parameter is used to specify the password which is used for encryption or decryption.

Value | Description
<password> | Password in clear text. It is not recommended to provide passwords in clear text. You should prefer using the /P parameter.


CC /P

/P

Syntax: /P

The /P parameter is used to specify a password which is used for encryption or decryption of the specified file. The password will not be displayed and you have to type in the password two times in order to ensure that the password is correct.

See also: /p


CC /kt

/kt

Syntax: /kt

The /kt (keep time) parameter can be used to encrypt or decrypt files without changing the file time (last modified date/time).


CC /!a

/!a

Syntax: /!a

The /!a parameter can be used to determine if a file is encrypted or not. A simple text message will be displayed which tells you if the file is encrypted or not.

See also: /!A, /f


CC /!A

/!A

Syntax: /!A

The /!A parameter works like the /!a parameter and can be used to determine if a file is encrypted or not. If the file is encrypted additional information will be displayed. This additional information contains the name and version of the application which was used to encrypt the file.

This feature is supported since Version 1.1. If an application from the CCrryyppttoo Suite with Version 1.0 was used to encrypt the file the application name cannot be determined. In this case the application name will be displayed as "(unknown)".

See also: /!a, /f


CC /!e

/!e

Syntax: /!e

The /!e parameter is used to encrypt a file. If the file is already encrypted an error message will be displayed and nothing happens. You can use the /!a or /!A parameter in order to determine if a file is encrypted or not.

See also: /!d, /f, /!a and /!A


CC /!d

/!d

Syntax: /!d

The /!d parameter is used to decrypt a file. If the file is not encrypted an error message will be displayed and nothing happens. You can use the /!a or /!A parameter in order to determine if a file is encrypted or not.

See also: /!e, /f, /!a and /!A