CCrrccppttoo Suite

CCrryyppttoo Suite

Version 1.1

This software is provided "as is" without warranty of any kind. The author disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall the author be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages.

Even though the 'CCrryyppttoo Suite' is freeware, it is not in the public domain, I reserve all rights to it. You may freely distribute copies of the 'CCrryyppttoo Suite' as long as you do so in an unmodified form and include all files and documentation that are present in the original archive. You may not charge for the distribution of the 'CCrryyppttoo Suite' other than a reasonable fee to cover your distribution costs.

Author

Harald-René Flasch
mailto:hfr@hfrmobile.com
http://www.hfrmobile.com

Suite

The CCrryyppttoo Suite consists of the following applications:

  • CCrryyppttoo
    • CPPC a)
    • cidll.dll b)
  • CCrryyppttoo Desktop
    • CC c)
    • CEE d)
a) CCrryyppttoo for Pocket PC
b) cidll.dll for Pocket PC used by Voyager. Voyager is a file explorer for Pocket PCs based on .NET technology
c) CCrryyppttoo Command
d) CCrryyppttoo Explorer Extension

CCrryyppttoo was tested with Windows CE 2.11, Windows CE 3.0 (PPC2002, WM2003) and Windows CE 4.2.

CCrryyppttoo Desktop was tested with Windows 2000 Professional, Windows XP Home Edition, Windows XP Professional and Windows Server 2003.

 | 1.0 1) | 1.1
Encryption / Decryption
CPPC | CPPC10 CPPC11 cidll10 cidll11 | CPPC10 CPPC11 cidll10 cidll11
Voyager/cidll.dll 2) | cidll10 cidll11 CPPC10 CPPC11 | cidll10 cidll11 CPPC10 CPPC11
CC | CC10 CC11 CEE10 CEE11 | CC10 CC11 CEE10 CEE11
CEE | CEE10 CEE11 CC10 CC11 | CEE10 CEE11 CC10 CC11
Encryption info 3)
CPPC | - | yes
Voyager/cidll.dll 2) | - | yes 1a)
CC | - | yes
CEE | - | no 1b)
Languages 4)
CPPC | e, g | e, g
Voyager/cidll.dll 2) | x 1c) | x 1c)
CC | e | e
CEE | e | e
Keep file time 5)
CPPC | - | yes
Voyager/cidll.dll 2) | - | yes 1d)
CC | - | yes
CEE | - | yes

1) The correct desktop version (CEE and CC) is 1.0 Beta1. There was never a Version 1.0. Next Version was already 1.1

2) The version number (column) is the cidll version number, not the version number of Voyager! cidll 1.1 is supported since Voyager 1.1 SP2

3) Information which application/version was used to encrypt a file

4) e = English, g = German, x = Language independent

5) This feature enables you to encrypt or decrypt a file without changing the "last modified" file time

1a) Available since Voyager 1.1 SP2 / cidll 1.1

1b) The CCrryyppttoo Explorer extension (CEE) stores the "Encryption info" but does not display it (you can use CC to display this information)

1c) cidll is language independent (the language of Voyager is not subject of this description)

1d) With Voyager 1.1 SP1 and Voyager 1.1 SP2 this setting can only be changed using the registry.


Voyager & cidll

The following list shows you all Voyager and CCrryyppttoo Integration versions:

Voyager | cidll
1.1 SP2 | 1.1
1.1 SP1 | 1.1 Beta1
1.1 Patch1 | 1.0
1.1 | 1.0
1.0 | 1.0
1.0 RC1 | 1.0
1.0 Beta3 | -
1.0 Beta2 | -
1.0 Beta1 | -